LinuxHappy's Weblog

Failures and Successes of Linux-based Development

Archive for July, 2008

Virtualbox on Ubuntu 7.10 Gutsy

Posted by linuxhappy on July 6, 2008

I bit the bullet this morning on (finally) upgrading my kernel headers from 2.6.22-14 to 2.6.22-15 on Ubuntu 7.10. I was holding off because I knew my binary nvidia drivers would be a pain, and I’ve been loaded up with things at work.. So, naturally –July 4th weekend is a perfect time to sit down and wrestle with all the fun linux version dependencies.

K, Nvidia drivers– a bit of a pain, I had to go through a series of uninstall/install/xorg.conf/envy massaging before I got it back to normal, but.. fine.. Virtualbox on the other hand… ugh. It was literally firing some fireworks straight into my face. KABLooy. I could write about it but I found an article that expresses exactly what I ran into:

http://www.terminally-incoherent.com/blog/2008/06/24/virtualbox-b0rken-by-gutsy-kernel-upgrade/

Basically moving from 2.6.22-14 to 2.6.22-15 — I guess there isn’t support for the 2.6.22-15 vboxdrv kernel module. Soo solution was to move from the OSE to the non-free binary under the PUEL License. Since this is for personal use– HOoorayY!. I tried compiling the OSE kernel modules for -15, but moving to this other version of virtual box was soo much easier. It even upgraded my Virtualbox config files under ~/.VirtualBox so that I didn’t loose any data from my host operating systems. Awesome!

Advertisements

Posted in Linux, Ubuntu | Tagged: | Leave a Comment »